ТОП-24 популярных формул в Excel

Количество просмотров: 
Отправим материал Вам на почту
Заполняя любую форму на сайте, вы соглашаетесь с политикой конфиденциальности

Чтобы облегчить пользователям работу, многие электронные таблицы имеют скрытые функции. Узнать о них для Excel предлагаем из нашей подборки. Мы собрали самые важные, которыми пользуются и обычные юзеры, и программисты, и бухгалтера.

Объединение текста

Чтобы соединить текст, используются разные формулы. Например, =СЦЕПИТЬ(А3;В3) позволит создать единый текст, написанный без пробела. Такой же функцией обладает и знак &, в таком случае пишут =А3&В3.

Чтобы разделить слова, нужно в конце каждой строчки ставить пробел самостоятельно или писать более сложную формулировку: =СЦЕПИТЬ(А3;» «;В3). Но это неудобно при работе с большим объемом данных.

СЦЕПИТЬ и & Excel

Еще одна команда =ОБЪЕДИНИТЬ(» «;ИСТИНА;D3:F3) включает:

  • символ разделения, указанный первым в кавычках;
  • истина/ложь обозначают, что пустые не обязательно/необходимо учитывать соответственно;
  • список объединяемых зон, среди которых вводят и обычные слова в кавычках.

Это часто требуется для объединения ФИО, если написано в разных колонках или строчках. Появляется строчка с полным содержимым.

ОБЪЕДИНИТЬ Excel

ИЛИ

Используется =ИЛИ для отображения правдивости введенной информации. Для этого в скобки помещают условие, выполнение которого нужно проверить, на выходе появляется уведомление «истина» или «ложь». Ее можно применять в качестве составной части более сложных формул, в зависимости от чего определяется дальнейшее действие. Сравнение осуществляется как по цифрам с помощью >, <, =, так и по тексту.

Например, создавая таблицу для участия в конкурсе, пользуются такой формулой. Для успешного прохождения на следующий уровень достаточно пройти тест и набрать 15 баллов и больше. Всем участникам дается три попытки.

ИЛИ Эксель

Нахождение по горизонтали и вертикали

Для этого вводят =ГПР, при этом в диапазон можно выделить как одну, так и несколько строк. Расшифровывается ГПР, как горизонтальный просмотр.

Вводится оператор в виде =ГПР, дальше в скобках:

  • Искомый параметр.
  • Таблица, она должна включать предыдущий компонент, в первой полосе, и возвратный, который располагают где угодно. Итог можно вставить в любом месте листа.
  • Строчку.
  • Интервальный просмотр. Если он не нужен, не указывайте его. Прописывается в виде «истина» – приблизительное или «ложь» – точное.

Большее распространение получило при подсчитывании бонусов там, где предусмотрена оплата труда с процентом от выручки.

Здесь показано, что действие осуществляется по первой строчке в пределах D1:G2, численного обозначения, максимально приближенного к Е5. Появится параметр со второй строки этого же столбца.

ГПР Эксель

Для поиска по вертикали прописывают ВПР, в итоге поиск производится по столбцу, а итог берется из строки. Таким образом, Е4 сравнивается с ячейками I, и данные выводятся из соответствующей ей части столбца J.

ВПР Эксель

ЕСЛИ

Проверяет конкретное условие и выводит заданный результат. Например, чтобы сравнить собственные расходы и доходы за месяц, вводят =ЕСЛИ(В2>А2;»Долги»;»Отпуск»). Ее можно совмещать с =ИЛИ. В этом случае количество вложений ограничивается 64. О чем речь: =ЕСЛИ(А4=0; “ДА”;ЕСЛИ(А4=1; “Нет”; “Возможно”)), и так может продолжаться 64 раза, но в этом случае найти ошибку будет проблематично. Ответом будет номер или текст. Чтобы далее использовать эту функцию, можно будет менять только первоначальное содержимое.

ЕСЛИ эксель

РАНГ

Это позволит определить порядковый номер по росту или убыванию. Таким образом, можно расположить расходы по мере их увеличения или убывания, узнать, какая статья расходов стала самой большой в месяце.

Для этого прописывают =РАНГ(В2;$B$2:$B$6;0) – это позволит отсортировать по уменьшению. Чтобы отсортировать их по увеличению, впишите последней единицу вместо нуля.

РАНГ эксель

МАКС

Это самая простая и полезная фишка – позволяет найти максимум из 255 чисел максимум. Поэтому можно сравнивать расходы не только за последний месяц, но и год. Для этого прописывают =МАКС(дают диапазон).

МАКС Эксель

МИН

Это противоположное показание – минимум, оценивается идентично, но оператор представлен =МИН(диапазон).

МИН EXCEL

СРЗНАЧ

Чтобы получить среднее арифметическое, указывают =СРЗНАЧ. Ограничиться можно именами или вводить сами числа.

СРЗНАЧ

СУММ

Это одна из наиболее известных функций, которая позволяет сложить неограниченное количество цифр, выбрать диапазон, задать его через точку с запятой и т.д.

Другой интересной ее интерпретацией является =СУММЕСЛИ, в таком случае можно суммировать их, если они соответствуют каким-либо условиям.

Например, если все прошедшие во 2 тур олимпиады сдали по 20 рублей на расходники, они могут приступить к выполнению заданий. Организатор контролирует сумму через условие =СУММЕСЛИ(G4:G6;»да»;H4:H6).

СУММЕСЛИ

Еще одна вариация =СУММЕСЛИМН подходит, если условий несколько, имеет более сложную структуру.

СЧЕТЕСЛИ

Определяет количество заполненных квадратов, которые будут учтены в расчете после прохождения проверки по =если. Здесь задается диапазон и критерий, который проверяют на актуальность.

Если вы хотите увидеть, какие статьи семейного бюджета тянут 10000 рублей в месяц и более, задайте =СЧЁТЕСЛИ(B2:B6;»>=10000″).

СЧЕТЕСЛИ

ЕСЛИОШИБКА

Позволяет уведомить пользователя, если в формуле ошибка. Если значение корректное, оно выводится в качестве результата. Вводится в виде =ЕСЛИОШИБКА(В2/С2;»Ошибка при вычислении»). Используется, если среди числовых есть текстовые наполнения.

ЕСЛИОШИБКА

ЛЕВСИМВ

Выделяет необходимое число символов слева, подходит для текстовых форматов. Выглядит, как =ЛЕВСИМВ(А5;60). Полезно для копирайтеров, которые проверяют, поместится ли заголовок в выдачу поисковой системы.

ЛЕВСИМВ

ПСТР

Здесь можно сохранить определенное количество знаков, начиная с любой точки отсчета. Это обусловлено особенностями формулы =ПСТР(А3;9;100). Это указывает, что в качестве основы берется содержимое А3, копирование начинается с 9 символа, выдержка содержит 100 знаков.

ПСТР

Регистр

Чтобы изменить регистр, используется оператор =ПРОПИСН и =СТРОЧН, далее вводится текст или дается ссылка на ячейку. =ПРОПНАЧ – замена строчных прописными и наоборот.

ПОИСКПОЗ

Расшифровывается, как поиск по значению. При этом можно искать точное совпадение или приблизительное соответствие. Для этого вводят =ПОИСКПОЗ(900;В2:В6;1), где 900 – искомое значение, далее указан изучаемый массив, последнее – тип сопоставления (1 – меньше или равно, 0 – точное, -1 – равно или больше).

ПОИСКПОЗ

ДЛСТР

Это длина строки в символах, которую можно узнать из =ДЛСТР(А1). Подходит для копирайтеров, контентщиков, менеджеров.

ДЛСТР

ПЕЧСИМВ

Ввод ее позволит убрать все невидимые знаки из статьи.

Это далеко не все возможности такой функциональной и удобной программы Excel, но они заслуживают внимания контент-менеджеров, бухгалтеров, экономистов, обычных людей.

Если вам нравится узнавать что-то новое, рекомендуем вам ознакомиться с 26 полезными функциями Яндекс.Вебмастера.

Как делегировать доступ к Google Search
22.09.2022
Улучшение органической выдачи Google
05.09.2022
Чем отличается контекстная реклама от таргетированной
02.09.2022
Появились вопросы?

Специалисты компании "Третий Путь" готовы ответить на все ваши вопросы по продвижению сайта, увеличению звонков и заявок на сайте.
Закажи звонок эксперта — мы свяжемся и ответим на все вопросы.